# 更新数据库版本

更新数据库版本可以提升性能,引入新功能,并修复集群中的错误。本文将指导您完成更新过程,并概述您应该考虑的注意事项。

# 注意事项

  • 一旦更新了数据库版本,不支持降级;
  • 每次更新数据库版本时,它将自动更新到最新版本;
  • 只有当集群处于“已启动”、“已停止”或“空闲”状态时,才能更新数据库版本;
  • 请注意,在数据库版本更新期间,当集群处于“已停止”状态时,读写操作将不可用;
  • 如果集群在升级期间处于“已启动”或“空闲”状态,单个副本集群可能会出现服务中断,读写操作可能会暂时失败;
  • 如果集群在升级期间处于“已启动”或“空闲”状态,多副本集群的写操作可能会暂时失败,但SELECT语句仍将正常工作;
  • 升级适用于数据库版本0.9.2.0或更高版本,包括版本0.9.2.0。

对于低于0.9.2.0的数据库版本,不支持自动更新。要使用最新的数据库版本,请创建一个新的集群并迁移您的数据。如果您希望导出数据库数据,请参考将结果导出到本地磁盘使用Insert Into将数据导出到S3

如有任何疑问,请联系我们

# 更新流程

当集群的数据库版本不是最新版本时,集群列表中将出现一个“更新”按钮,如下图所示。

更新数据库版本

点击“更新”按钮,您可以启动升级过程。